Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

Installed SC901 and 4 x 50 Amp, no sound except for dash

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, including 850 R, 850 T-5R, 850 T-5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
dad2three
Posts: 17
Joined: Fri May 08, 2015 4:26 pm
Year and Model: 99 V70 GLT
Location: Madison, WI
Has thanked: 3 times

Installed SC901 and 4 x 50 Amp, no sound except for dash

Post by dad2three »

I've tried searching for an answer, but couldn't find anything. Last fall I purchased an SC901 HU and factory amp. It came with a factory wiring harness. I finally got around to installing today. When all hooked up, I only get sound to the dash speakers.

I think I have the harness connected properly- the 14 pin female on the "amp" harness is connected to the 14 pin male from "car" harness, 14 pin male from amp harness is plugged into the back of the HU, the 10 pin connector with the yellow/black wire is plugged into the back of the HU, the 6 pin DIN connector, antenna, and other round cable all plugged into their appropriate locations.

Do I have everything plugged in correctly? Could the amp be bad?
Darrin
99 V70 GLT

scot850
Posts: 6758
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 22 times
Been thanked: 333 times

Post by scot850 »

It is impossible to fit wiring wrong as they are keyed so I don't think you have done it wrong. Did yo have the other speakers working ok with your old radio? Was the previous radio a Volvo one? If so, swap the old radio back in (they should all be compatible with the amp wiring) and see if you get all the speakers working.

Try re-checking the wiring to ensure it has been pushed fully home. All connectors should snap home.

Finally, try pulling the HU back out of the dash, check the connectors and see if it runs ok with the HU sitting loose. Sometimes when pushing the HU back into the dash you can trap the wires.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

dad2three
Posts: 17
Joined: Fri May 08, 2015 4:26 pm
Year and Model: 99 V70 GLT
Location: Madison, WI
Has thanked: 3 times

Post by dad2three »

Thanks, I did try reconnecting everything as well as having it just sit in the hole versus pushed in place.

I haven't tried using the amp with the other HU, I can switch it out.

When it is all hooked up the 10 pin harness from the car is not used, correct?
Darrin
99 V70 GLT

User avatar
BEJinFbk
Posts: 3824
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 39 times
Been thanked: 67 times

Post by BEJinFbk »

dad2three wrote: Sun Jun 21, 2020 5:35 pm When it is all hooked up the 10 pin harness from the car is not used, correct?
Good News!
That’s where the outboard amp ties back into your 4 corners of speakers,
so you’re day is gonna get a whole lot better when you plug it in. :wink:
'98 V70 R - Well Equipped for Life Up North... ;)

dad2three
Posts: 17
Joined: Fri May 08, 2015 4:26 pm
Year and Model: 99 V70 GLT
Location: Madison, WI
Has thanked: 3 times

Post by dad2three »

BEJinFbk wrote: Sun Jun 21, 2020 11:35 pm
dad2three wrote: Sun Jun 21, 2020 5:35 pm When it is all hooked up the 10 pin harness from the car is not used, correct?
Good News!
That’s where the outboard amp ties back into your 4 corners of speakers,
so you’re day is gonna get a whole lot better when you plug it in. :wink:
I thought so, but I don't see where it plugs in. Am I missing part of the harness? Coming up from the amp I only have:
  • 6 pin DIN
    14 pin female end
    14 pin male end
    10 pin male w/ a single yellow/black wire
The amp side has 6 pin DIN, 14 point, and a green end connector.
Darrin
99 V70 GLT

scot850
Posts: 6758
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 22 times
Been thanked: 333 times

Post by scot850 »

Here is a complete harness, without the Dolby option.

Basics are, the 2 cables that used to plug into the back of the standard radio/HU connect to the amp cable instead and basically run to the amp and then back to the HU (the SC-900/901 do not have internal amps).

Below is a complete AMP harness:
SC-901 amp harness
SC-901 amp harness
Cable end (1)
Cable end (1)
This end is all the connections at the amp. The black plastic rectangle on the harness (sitting on the keyboard) is the part that holds the cable on the passenger side of the center console.
Cable end (2)
Cable end (2)
This is the ''new' connections to the HU.
Middle of cable
Middle of cable
These connect to the original HU cable that went to the back of the HU.

Does this help?

Back of SC-901 with amp wiring:
Rear connections to SC-901
Rear connections to SC-901
Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

User avatar
BEJinFbk
Posts: 3824
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 39 times
Been thanked: 67 times

Post by BEJinFbk »

A little more on this topic:

viewtopic.php?t=30204
'98 V70 R - Well Equipped for Life Up North... ;)

dad2three
Posts: 17
Joined: Fri May 08, 2015 4:26 pm
Year and Model: 99 V70 GLT
Location: Madison, WI
Has thanked: 3 times

Post by dad2three »

scot850 wrote: Mon Jun 22, 2020 12:38 pm Here is a complete harness, without the Dolby option.

Basics are, the 2 cables that used to plug into the back of the standard radio/HU connect to the amp cable instead and basically run to the amp and then back to the HU (the SC-900/901 do not have internal amps).

Below is a complete AMP harness:

Wiring Harness SC900-901 to amplifier 001.JPG

Wiring Harness SC900-901 to amplifier 002.JPG

This end is all the connections at the amp. The black plastic rectangle on the harness (sitting on the keyboard) is the part that holds the cable on the passenger side of the center console.

Wiring Harness SC900-901 to amplifier 003.JPG

This is the ''new' connections to the HU.

Wiring Harness SC900-901 to amplifier 004.JPG

These connect to the original HU cable that went to the back of the HU.

Does this help?

Back of SC-901 with amp wiring:

2015-03-16 22.08.21.jpg

Neil.
Perfect, thank you. Thinking I didn't fish up the other 10 pin connector. The pictures are greatly appreciated.
Darrin
99 V70 GLT

scot850
Posts: 6758
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 22 times
Been thanked: 333 times

Post by scot850 »

Hope it fixes the issue. That's what always make the effort worthwhile.

Good Luck!

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

User avatar
BEJinFbk
Posts: 3824
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 39 times
Been thanked: 67 times

Post by BEJinFbk »

You’re going to love this system.
Then you’ll want a sub... 😎
'98 V70 R - Well Equipped for Life Up North... ;)

Post Reply