Login Register

parking sensor assist

Third generation Volvo V70 wagon and XC70, and second generation S80. Are you an owner? Prospective owner? Get in here and join us! Start a new topic or comment on an existing thread.

2008-2016 V70
2008-2016 XC70
2007-2016 S80

Post Reply
User avatar
RickHaleParker
Posts: 6997
Joined: 25 May 2015, 14:30
Year and Model: See Signature below.
Location: Kansas
Has thanked: 8 times
Been thanked: 900 times

Re: parking sensor assist

Post by RickHaleParker »

Ibro wrote: 07 Jan 2022, 01:14 What do you suggest buy a new module with new number and get harness and sensors ?
It is hard to say what the PO did. Either way it comes down to a bet.

I would try to find something that works with the module you have. I would look for a four sensor harness with four sensors in a salvage yard because your diagnostic software is calling for four sensors. That way if its wrong you don't loose much.
⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

Ibro
Posts: 33
Joined: 11 Nov 2018, 12:40
Year and Model: 2003 s60
Location: Israel

Post by Ibro »

Thanks

So which harness code i should go for ?

Also i had the code u015900 lost communication with parking assistance module

Could this mean also the module is bad ?

User avatar
RickHaleParker
Posts: 6997
Joined: 25 May 2015, 14:30
Year and Model: See Signature below.
Location: Kansas
Has thanked: 8 times
Been thanked: 900 times

Post by RickHaleParker »

Ibro wrote: 07 Jan 2022, 05:20 Also i had the code u015900 lost communication with parking assistance module

Could this mean also the module is bad ?
That would be the place to start. See if you can get the PAM communication restored. It is looking more and more like the PO wrecked the front end and replaced the damaged electrical with the wrong parts.

Volvo DTC CEM-U015900

Definition:
CEM Lost Communication With Parking assistance module. General Failure Information

Description:
The control modules communicate with each other for exchange of information in a network via a standardized serial communication procedure - CAN (Controller Area Network). The diagnostic trouble code (DTC) is stored if the control module detects that: Interrupted or no communication with the Parking Assistance Module (PAM). The control module's test for the diagnostic trouble code (DTC) starts in the event of: Ignition switch position II. Note! The control module can only detect the fault once the test has been started and the diagnostic trouble code (DTC) is stored when the conditions are met. The diagnostic trouble code (DTC) indicates a fault in the communication across the CAN network and does not isolate an individual node. Do not replace the central electronic module (CEM) unless fault-tracing indicates a damaged control module

Causes:
  • Voltage feed to Parking Assistance Module (PAM) missing.
    Open circuit on ground cable to Parking Assistance Module (PAM).
    Contact resistance in the terminals.
    Open-circuit or short-circuit in the wiring for the control area network (CAN).
    Parking Assistance Module (PAM) not intended for this car, e. g. , used control module with other hardware/software.
⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

Ibro
Posts: 33
Joined: 11 Nov 2018, 12:40
Year and Model: 2003 s60
Location: Israel

Post by Ibro »

Thanks a lot for your help

So which harness code should i get please ?

The car has headlight washers but are not there . However when the car was lifter i noticed the washers had cables connected to them


I am going to try to get a module as well, i shall look for the new module code 31341090? As the old number is discontinued


Regards

User avatar
RickHaleParker
Posts: 6997
Joined: 25 May 2015, 14:30
Year and Model: See Signature below.
Location: Kansas
Has thanked: 8 times
Been thanked: 900 times

Post by RickHaleParker »

Nobody can say what you should do. You need to place your bet and own it.
I would find a salvage S80 with park assist and head light washer then take the whole system.
⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙⸙
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

Ibro
Posts: 33
Joined: 11 Nov 2018, 12:40
Year and Model: 2003 s60
Location: Israel

Post by Ibro »

Yes this is what i plan to do. Find a salvage car and get the parts off it

The parts that do not work i can return them so it would not be a problem .

Of course as you said first we should stick to the can vin and take those parts . Thats what i will do first

Will get a harness with the washer connectors abd maybe try to find a module that has the new number

Ibro
Posts: 33
Joined: 11 Nov 2018, 12:40
Year and Model: 2003 s60
Location: Israel

Post by Ibro »

hi

one quick question please

i checkd the part number Wire Harness - Volvo (31260291)
2008-2010 - it is indicating it is for 2008-2010 the car i have is 2011. will that make a difference ?

as in a day or two i might go to the used cars yard to get the wires . so i need to make sure this wire is the one. or for 2011 i should get another code.

thanks

Ibro
Posts: 33
Joined: 11 Nov 2018, 12:40
Year and Model: 2003 s60
Location: Israel

Post by Ibro »

Hello

To update on this . Tried to get all used parts same problem.

Got new module, has a new code . New wires and still the same problem. The electrician working on it said the current is ok in the wiring and does not seem to find any logical reason for this.


Is there a way for example to disable the front sensors? Or there is any other components i am missing that need to be checked ?

Thanks

lntravler
Posts: 4
Joined: 25 Oct 2021, 09:44
Year and Model: 2009 s80 t6
Location: Us

Post by lntravler »

New module need update software, otherwise even it works physically, the dash will pop up error message

Post Reply
  • Similar Topics
    Replies
    Views
    Last post