IPD sale XeMODeX - Experts in Volvo Electronics

Search found 0 matches

by Lolvolol
Fri Apr 17, 2020 8:55 pm
Forum: Volvo Classifieds
Topic: ISO: S70 Manual, Arkansas
Replies: 0
Views: 108

ISO: S70 Manual, Arkansas

Looking for a S70 manual anywhere around Arkansas.
by Lolvolol
Sun Apr 12, 2020 1:01 pm
Forum: Volvo Classifieds
Topic: For Sale: 97 850 T5 auto $2750, Russellville AR
Replies: 0
Views: 187

For Sale: 97 850 T5 auto $2750, Russellville AR

I have a 97 T5 auto 850 with a silver exterior and blue interior. 105k on the WORKING odometer (replaced the last cluster that was reading 85000 about five months ago). Car is mechanically sound except for a check engine on for a speed sensor. Cosmetically it has some paint scratches near the exhaus...
by Lolvolol
Fri Jan 03, 2020 9:39 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: 97 850 T5 Code p0500 headache
Replies: 4
Views: 212

Re: 97 850 T5 Code p0500 headache

So I initially replaced 12b and 12a, and now I’m trying to replaced 5 and I cannot figure out where the two male prongs go to. I don’t see any type of harness, to me it looks like the pre-existing wire for 5 goes into 38 for some reason, am I fiddling with the wrong sensor? bare with me here, I’m ve...
by Lolvolol
Fri Dec 27, 2019 7:47 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: 97 850 T5 Code p0500 headache
Replies: 4
Views: 212

Re: 97 850 T5 Code p0500 headache

I read pretty much every post I could find prior to posting, but I just did a part search with the part number he posted and it’s slightly different than the sensor I replaced, any idea the best way to get to that other sensor with the two prong connection?
by Lolvolol
Fri Dec 27, 2019 5:36 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: 97 850 T5 Code p0500 headache
Replies: 4
Views: 212

97 850 T5 Code p0500 headache

So I have the dreaded flashing up arrow and check engine light with 1 code...p0500. First I tried rowing the shifter about 30 times back and forth to no avail, then I tried replacing the sensor that’s under the air intake tube almost directly under the brake fluid reservoir with this part (see pictu...
by Lolvolol
Wed Dec 11, 2019 5:15 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Cam timing and MAF/02 Scan readings
Replies: 1
Views: 191

Cam timing and MAF/02 Scan readings

So I’ve got a camshaft position sensor A performance code, and not knowing what to check first I checked the timing. Now I don’t know much about cam/crank timing and all of that, but I believe the tooth is supposed to be aligned with the little notch in the cover. The second to last picture I circle...
by Lolvolol
Sun Dec 08, 2019 2:04 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: P0440 and P0172 mystery
Replies: 9
Views: 270

Re: P0440 and P0172 mystery

All connections are good, acts like a different car now. Codes are gone. Thanks for all of the help guys.
by Lolvolol
Sat Dec 07, 2019 4:56 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: P0440 and P0172 mystery
Replies: 9
Views: 270

Re: P0440 and P0172 mystery

misha wrote: Sat Dec 07, 2019 4:03 pm Hose from purge valve goes to metal nipple at intake manifold...that's correct routine.
Remove negative battery terminal for about 10-15 min in order to clear the codes and reset fuel trims.
Then....do a re-learning procedure for ecu and see which codes are coming back.

Gotcha. Will update
by Lolvolol
Sat Dec 07, 2019 3:55 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: P0440 and P0172 mystery
Replies: 9
Views: 270

Re: P0440 and P0172 mystery

So I figured it out somehow. The cruise control vacuum hose was hooked up to the evap purge valve and then led to nothing, and the hose that was supposed to be hooked up to the purge valve was plugged into the intake manifold. So I unplugged the cruise control hose and plugged it into the the cruise...
by Lolvolol
Fri Dec 06, 2019 10:07 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: P0440 and P0172 mystery
Replies: 9
Views: 270

Re: P0440 and P0172 mystery

The one coming from the underside of the car is connected, and the hose I’m holding is the one that is coming out of the other side of the purge valve. So does that mean this hose routes all the way to the air intake? If so I’ll have to get some more hose, this one won’t reach near that far. Also it...
by Lolvolol
Fri Dec 06, 2019 8:44 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: P0440 and P0172 mystery
Replies: 9
Views: 270

P0440 and P0172 mystery

97 850 T-5 here, I have a troublesome strand of issues that I assume are related. First off, I’m getting two codes: P0440 and P0172, and I have a mystery hose that I assume is apart of the EVAP system that I cannot seem to figure out. It’s sitting on the drivers side of the fan shroud and is hooked ...
by Lolvolol
Fri Oct 04, 2019 4:59 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

I got off of work today and rushed home to install the new cluster I ordered. I put it in and put everything back together... and it works! So I’m pretty happy about all of that. Thanks for all of your input!
by Lolvolol
Sun Sep 29, 2019 12:14 pm
Forum: Volvo Classifieds
Topic: Volvo 850, S/V70, and R Parts - New Haven, CT
Replies: 29
Views: 2294

Re: Volvo 850, S/V70, and R Parts - New Haven, CT

What year 850 instrument clusters do you have? I’m looking for a 97 VDO with turbo gauge
by Lolvolol
Sat Sep 28, 2019 11:25 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

misha wrote: Sat Sep 28, 2019 5:35 pm Allready pointed you into a right direction...few posts earlier.
I did check out erie’s Ebay and found one on there going for around 100...but I haven’t seen any junkyards around here with any Volvo’s.
by Lolvolol
Sat Sep 28, 2019 11:21 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

Something else I just noticed is that my clock is staying on constantly now, and the clock is the only thing that works other than the boost gauge. It’s odd to me that the clock will appear, but the info screens will not. The boost gauge is mechanical and I assume the clock would normally be showin...
by Lolvolol
Sat Sep 28, 2019 5:15 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

misha wrote: Sat Sep 28, 2019 4:28 pm The only way to fix the issue or at least to find out if it' just a bad cluster....is to replace it with a used unit.
And that’s what I’ll try. Any recommendations as far as finding a reliable source on one?
by Lolvolol
Sat Sep 28, 2019 12:16 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

It might be a good idea to check the connector at the ABS control module and the connectors going into the back of the instrument cluster. If they're loose, corroded or damaged they could cause the gauges to stop working. Something else I just noticed is that my clock is staying on constantly now, ...
by Lolvolol
Sat Sep 28, 2019 11:55 am
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

It is definitely applied during manufacturing. Seen it plenty of times over the years. Not seeing it on others might be due to the rolling changes often made during production. Such as, it's been discovered these sections need corrosion protection. Okay I gotcha. Thanks for clearing that up. Not to...
by Lolvolol
Sat Sep 28, 2019 11:08 am
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

That looks a factory applied conformal coating. If you take a closer look, it’s been used around of the surface mounted capacitors and resistors It’s used as protective layer. That’s odd, I’ve looked at pictures of other 850 clusters and didn’t see the same coating. But if it’s intentional, then th...
by Lolvolol
Sat Sep 28, 2019 9:53 am
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

I have a 1993 940 that had a wonky fuel gauge that was intermittent, and things went downhill from there. I pulled the instrument cluster and resoldered (heated and added a bit of new electronics solder) all of the connections. Everything started working again. The heat/cool cycle and hidden corros...
by Lolvolol
Fri Sep 27, 2019 10:50 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

I have a 1993 940 that had a wonky fuel gauge that was intermittent, and things went downhill from there. I pulled the instrument cluster and resoldered (heated and added a bit of new electronics solder) all of the connections. Everything started working again. The heat/cool cycle and hidden corros...
by Lolvolol
Fri Sep 27, 2019 6:49 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

It might be a good idea to check the connector at the ABS control module and the connectors going into the back of the instrument cluster. If they're loose, corroded or damaged they could cause the gauges to stop working. Something else I just noticed is that my clock is staying on constantly now, ...
by Lolvolol
Fri Sep 27, 2019 10:23 am
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

Could be I suppose, but from looking at other pictures I don’t see any with this type of coating on it. I’ll post pictures later
by Lolvolol
Fri Sep 27, 2019 6:42 am
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Re: Instrument Cluster Failure

It might be a good idea to check the connector at the ABS control module and the connectors going into the back of the instrument cluster. If they're loose, corroded or damaged they could cause the gauges to stop working. I just noticed something that I overlooked apparently, on the instrument clus...
by Lolvolol
Thu Sep 26, 2019 7:15 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: Instrument Cluster Failure
Replies: 27
Views: 625

Instrument Cluster Failure

Buckle up, this might take a minute to explain. I just bought a 97 Volvo 850 turbo t5 from a not so trustworthy character about a month ago now, among numerous other issues the speedo, tach, fuel gauge and temp gauge all stopped working suddenly after not driving it for a few days (the odo and trip ...