Search found 14 matches

by MrBreeze
Sat May 04, 2019 6:21 am
Forum: Volvo XC90 Forum
Topic: 2008 XC90 3.2 P0442 & P0037
Replies: 2
Views: 271
United States of America

Re: 2008 XC90 3.2 P0442 & P0037

P0442 is back, seems to happen after getting gas, so will replace gas cap next, if that does not solve it, will smoke test it.
by MrBreeze
Sat Apr 06, 2019 8:15 pm
Forum: Volvo XC90 Forum
Topic: 2008 XC90 3.2 P0442 & P0037
Replies: 2
Views: 271
United States of America

Re: 2008 XC90 3.2 P0442 & P0037

Follow up..... P0037 was corrected with new Densor O2 sensor, Bank 1 Sensor 2 was passenger side down flow sensor, tested old sensor no reading on the ohm meter, after replacement with new sensor code was gone. P0442 - decided to replace J Hose since 90% of the time that is the culprit. Pulled old h...
by MrBreeze
Mon Mar 18, 2019 8:08 pm
Forum: Volvo XC90 Forum
Topic: 2008 XC90 3.2 P0442 & P0037
Replies: 2
Views: 271
United States of America

2008 XC90 3.2 P0442 & P0037

Just picked up a nice 08 XC90 3.2 AWD with only 99K Throwing 2 codes P0037 HO2S Heater Control Circuit Low Bank 1 Sensor 2 P0442 Evaporative Emission system Leak detected (small leak) Have read lots of posts on P0442, that looks like a wild goose chase, but will start with gas cap & J Hose inspectio...
by MrBreeze
Fri Mar 08, 2019 9:34 pm
Forum: Volvo XC90 Forum
Topic: Another Anti-Skid Question
Replies: 17
Views: 1076
United States of America

Re: Another Anti-Skid Question

Be sure if you replace the clock spring that you are aware if your vehicle has DTSC or not, there are two different units, one for each.

I have purchased used and tested clock spring units on EBay for half the price of new with much success.
by MrBreeze
Tue Mar 05, 2019 7:14 pm
Forum: Volvo S80 Forum - First Generation 1999-2006
Topic: 2007 S80 3.2 semi hard shift
Replies: 1
Views: 171
United States of America

2007 S80 3.2 semi hard shift

Just picked up a 2007 Volvo S80 3.2L with 102K miles, when cold the shifts are very pronounced at medium acceleration. Car is in comfort setting, I have not attempted a comparison in Sport mode yet. Seems to happen when cold, after a warm up the shifts smoothed out for the most part. Gear mount? Cha...
by MrBreeze
Tue Feb 26, 2019 6:10 am
Forum: Volvo XC90 Forum
Topic: just picked up 2010 R Design need help
Replies: 10
Views: 520
United States of America

Re: just picked up 2010 R Design need help

Removed radio head from dash and had light in the fiber optic, light in the amp, but no light in the Nav unit under front seat, so figured a break between amp -Sat -Nav, initially I had checked the radio 10 amp fuse, and it was fine, decided to go back and check the 30 amp Amplifier fuse, lo and beh...
by MrBreeze
Tue Feb 19, 2019 4:30 am
Forum: Volvo XC90 Forum
Topic: just picked up 2010 R Design need help
Replies: 10
Views: 520
United States of America

Re: just picked up 2010 R Design need help

I will be removing the radio from dash and checking if there is fiber optic light coming from the unit, starting there, then will bypass other units if it is working. The Nav unit isn't working either. Have driven about 200 miles since my original post, the shudder only happens about 10-20% of the t...
by MrBreeze
Sun Feb 17, 2019 8:36 pm
Forum: Volvo XC90 Forum
Topic: just picked up 2010 R Design need help
Replies: 10
Views: 520
United States of America

Re: just picked up 2010 R Design need help

in regards to the XC90 front right axle, does the same part fit R-Design and non R models?

anyone use after market parts? https://www.rockauto.com/en/moreinfo.ph ... 31&jsn=434
by MrBreeze
Sun Feb 17, 2019 8:27 pm
Forum: Volvo XC90 Forum
Topic: just picked up 2010 R Design need help
Replies: 10
Views: 520
United States of America

Re: just picked up 2010 R Design need help

Found this for the infotainment blank screen maybe?

https://xemodex.com/us/product/infotain ... 236-10-20/

$349.00 shipped both ways.

Will do some more research on this.
by MrBreeze
Sat Feb 16, 2019 9:13 pm
Forum: Volvo XC90 Forum
Topic: just picked up 2010 R Design need help
Replies: 10
Views: 520
United States of America

just picked up 2010 R Design need help

Just picked up a 2010 XC90 R-Design with 132K miles. Two issues I need to address, The radio display is blank - turn on power and the Performance Sound logo comes on then nothing, no sound or display. Am able to access audio menu for treble/bass etc and the scale displays and responds to adjustments...