IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

98 V70 T5 rough idle after warm up, eventually stalls... Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Sat Oct 13, 2018 8:59 am

Symptoms started 2 weeks ago: Starts/idles fine for the first 10-15 min. and then begins to stumble/idle rough. I can feather out of the rough idle up to 1500-2000 rpms and it runs smooth; goose the accelerator, the stumbling returns. Once back down to idle (rough) and shut it off, it wont start for at least an hour or until its cooled down. Same symptoms under load (driving). New plugs, cap/rotor (10K miles on them), last week cleaned MAF, plugs... no change. CEL illuminated, ran OBD code P0102 (from removing MAF), cleared code and started engine until it stalled (under load). CEL illuminated until I got it running again, then CEL disappears (still rough idle). Ran OBD again and nothing, no codes. Also, changed coil, fuel pump relay and installed new crankshaft position sensor. Yesterday performed the scientific glove over oil refill test, glove inflates when rpms increase, should suck glove in. New PCV (FCP kit) was installed 100K ago. PCV clog? Cat? Still not throwing any codes.

scot850
Posts: 5764
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 188 times
Canada
scot850

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by scot850 » Sat Oct 13, 2018 2:24 pm

Check the ECT temp sensor. It is the coolant sensor. Check the connector on the back of the power steering pump. The connector/wire/pins are bad at this age for failing. Somewhere on here there are resistance specs for the sensor at various ambient temperatures. If you find it is bad, heed the warnings of OE or OEM ONLY part should be used.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Sat Oct 13, 2018 2:51 pm

Thank you Neil. ECT is next on my list as the replaced (today) used cam position sensor didn't make a difference. Thought it was fixed because it took much longer to stumble, but its much cooler outside now and eventually idled rough until I intentionally stalled it hoping to get a code.

David

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Sat Oct 13, 2018 3:11 pm

Just ran OBD after the most recent rough stall, finally got some codes! Code: 300, 303, 305. Cylinder misfires, not sure why it occurs until the engine warms up.

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Wed Oct 17, 2018 1:35 pm

Just replaced the thermostat and ECT...same problems...stumped. Time for a beer.

User avatar
abscate
MVS Moderator
Posts: 20462
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 285 times
Been thanked: 898 times
Trinidad & Tobago
abscate

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by abscate » Wed Oct 17, 2018 1:50 pm

Time to dive in and replace PCV, vacuum hoses, intake manifold.

Remember the slightest leak in induction will cause bad running.

Oh, 1998 fooled me
Check fuel pressure with gauge and/or visual remove inspect the fuel pressure regulator for popped diaphragm
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Wed Oct 17, 2018 1:56 pm

abscate wrote:
Wed Oct 17, 2018 1:50 pm
Time to dive in and replace PCV, vacuum hoses, intake manifold.

Remember the slightest leak in induction will cause bad running.
Whats frustrating is that its runs great for 15-20 minutes (depending on outside temp.), then all goes to hell. Very consistent in terms of when it starts to act up.

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by valvolvo70 » Thu Jan 03, 2019 5:25 pm

Not going to give up on her! I work from home/self-employed, so being down one vehicle isn't critical, more of a nuisance. UPDATE: Same issues after cleaning throttle body, IAC and new NGK copper plugs (along with all the other cheap/easy stuff mentioned above). Also checked fuel pressure by pressing the fuel rail schrader valve. Haven't started it for a week but no fuel came out!. Primed it twice with key II position, fuel streamed out (not spray) and stopped draining after a second. Jumped the fuel pump relay and pump ran constantly, still no improvement in engine idle/performance (new-ish fuel pump has 40K on it). Now this has happened once before and I repeated it today. Starts fine cold, but as opposed to letting it sit and idle, I warm it up to temp by idling around 1500-2000 RPMS. With a higher idle, the engine doesn't misfire/stall so easily unlike normal idle conditions around 1000 RPMS. Its actually difficult to stall even though its stumbling. After several attempts to stall, so I could get a code, I smelled fuel/rotten egg/sulfur mix in the cabin along with a CEL and a NEW P0440 code (EVAP). After researching 440 code on MVS most of the day today, I found good info with similar symptoms. As "abscate" mentioned above, my troubles seem to point to fuel pump regulator (I know its uncommon) or rollover valve and/or leaky vac lines within the vicinity. Ill be underneath for a visual inspection tomorrow. Any additional thoughts would be appreciated.

santacreu
Posts: 1
Joined: Wed May 28, 2014 11:56 am
Year and Model: V70 2.4 T 2001
Location: Brazil
Has thanked: 0
Been thanked: 0
santacreu

Re: 98 V70 T5 rough idle after warm up, eventually stalls...

Post by santacreu » Sun May 19, 2019 6:37 am

Hi, I’m having the same problem on my 2000 V70 2.4 turbo. I have an external thermometer in the thermostat valve body and notice that the engine starts to stall when the thermostat valve starts to open and the local temperatutre in the ECT drops one or two degrees before continue to warm again. If I shoot engine down, wait a minute, let temperature raise again it will start and idle OK. If the day is cold every time the temperature drops below 80 Celsius the engine stalls again.
1995 Volvo 850 sw 2.3 turbo
2000 Volvo V70 sw 2.4 turbo
2002 Land Rover Defender 110

valvolvo70
Posts: 20
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5
Location: Michigan
Has thanked: 3 times
Been thanked: 2 times
United States of America
valvolvo70

Re: 98 V70 T5 rough idle after warm up, eventually stalls...  Topic is solved

Post by valvolvo70 » Mon Jun 24, 2019 2:10 pm

***UPDATE***Problem Solved!
We hosted a family Memorial Day get together last month and my niece's fiancee manages a Volvo parts department (didn't know this). Lifted the hood while explaining my symptoms over a few beers and he suggested replacing the Pulse Damper. He's experienced similar symptoms in other customers Volvo's, and most led back the the damper. Found a used damper on Ebay for $15 and I'm back on the road again after 10 months of troubleshooting!. I've been driving longer distances the past 2 weeks as a test before I posted my fix.

Thank you for all the responses and guidance. Great Forum!

PS- I looked everywhere for a new pusle damper, all the parts specialist sites listed their pusle damper as "discontinued", is that right?
These users thanked the author valvolvo70 for the post (total 2):
brunocerousmfenimore

Post Reply
  • Similar Topics
    Replies
    Views
    Last post