Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

2006 S60 2.5T stuttering mystery Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive P2 platform cars sold as model years 2001-2007 (North American market year designations).

2001 - 2007 V70
2001 - 2004 V70 XC (Cross Country)
2004 - 2007 XC70 (Cross Country)
2001 - 2009 S60
2003 - 2007 S60 R
2004 - 2007 V70 R

Post Reply
User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Volvo Repair Database 2006 S60 2.5T stuttering mystery

Post by RSAmbassador »

I just recently purchased a 2006 S60 2.5T with 108xxx miles on it. I've had it for three weeks or so and recently it started to develop a bad stutter when given heavy acceleration. But when in park and revved it wont stutter or miss. I just recently changed the spark plugs and the problem still persists. I've read about issues with the FPS, MAF, and Ignition Coils causing this. The major mystery is its not throwing a check engine light. Has anyone else ran into this problem? I'm just trying to put a line out here to try and find the least expensive answer to resolve my problem. Thanks!

User avatar
matthew1
Site Admin
Posts: 11121
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 768 times
Been thanked: 334 times

Post by matthew1 »

How's the car on the Stage 0 items? Can you record a video of the stutter?
Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

Image

User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Post by RSAmbassador »

Far as I know the car is completely stock. I can get a video up in a few hours. I just took it to see if anything would pull up in codes and alas nothing did. But at light throttle and cruising speeds it doesn't stutter but on inclines it does. It's like a jerk and the RPM drops. But when in the range of 50-70MPH it occasionally stutters. If you goose it stutters a bunch, normally gets worse when the engine is running at temperature.

User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Post by RSAmbassador »

Also here's the list of things I've done since getting the car:
Changed out the oil to Castrol Edge 5w-30 Synthetic Oil and replaced oil filter with a Mann filter.
Replaced Position Lights in the trunk
and placed Seafoam in the oil and fuel.

User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Post by RSAmbassador »

So here's a video excuse my horrible speaking voice and accent, hopefully you can hear it. But you can see the camera shake when it happens. Thanks!

User avatar
oragex
Posts: 5281
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 102 times
Been thanked: 325 times
Contact:

Post by oragex »

get a used ignition coil and replace them one by one then test. no need to replace them all, just the faulty one. also have a look at all the wires to the ignition coils, sometimes these get crushed under the plastic cover.

if that's not the issue, I'd look into the FPS sensor.

User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Post by RSAmbassador »

Not a bad idea, but I'll have to pony up probably and buy a new coil but it's worth a shot. I checked the cables as I changed then plugs they were fine

Cookie-the-Swede
Posts: 60
Joined: Fri Oct 07, 2016 9:35 am
Year and Model: 2003 S60 2.5T AWD
Location: Telluride, CO. USA
Has thanked: 1 time
Been thanked: 4 times

Post by Cookie-the-Swede »

Putting Seafoam in the crankcase can be problematic.

User avatar
RSAmbassador
Posts: 26
Joined: Thu Apr 06, 2017 12:01 pm
Year and Model: 2006 S60 2.5T
Location: Kentucky

Post by RSAmbassador »

So a brief update on this. I was driving Bette (my affectionate nickname for my Vo) I noticed the stutter gets worse when there's less fuel in the car. Maybe a tell tale sign of a FPS issue?

chrism
Posts: 1074
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Been thanked: 29 times

Post by chrism »

You might try calling Volvo Customer Care. Give them the VIN and see if your's is eligible for, and/or, ever received the Volvo one-time free FPS replacement.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post