2002 S60: Instrument panel not working

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive P2 platform cars sold as model years 2001-2007 (North American market year designations).

2001 - 2007 V70
2001 - 2004 V70 XC (Cross Country)
2004 - 2007 XC70 (Cross Country)
2001 - 2009 S60
2003 - 2007 S60 R
2004 - 2007 V70 R

Post Reply
Yaworski
Posts: 66
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 3 times

2002 S60: Instrument panel not working

Post by Yaworski »

I've reported elsewhere about my brake issues. So I picked the car up yesterday afternoon. From sitting, the battery was dead so I jumped it. Vroom, started up right away. I don't notice the brake pulling that the mechanic was talking about so maybe everything is alright.

How's this relate to the instruments? Well, I was headed home and noticed that the gas gauge was on E. Then I noticed that the speedo wasn't indicating anything and neither was the tach.

A/C works as do the headlights, radio, door locks, and interior lights.

Before I head back to the mechanic, yelling and screaming, what should I look at first? Is there a master fuse?

chrism
Posts: 1072
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Been thanked: 28 times

Post by chrism »

Is EVERYTHING in the instrument cluster (DIM), like all the warning lights at start up, etc, non-functioning? Or are some things working and some things dead?

Yaworski
Posts: 66
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 3 times

Post by Yaworski »

Every thing is dead. No tach, no speedo, no idiot lights . . .I don't think that the lights for the instrument cluster are working either.

User avatar
yagger
Posts: 348
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 6 times
Been thanked: 31 times

Post by yagger »

for 2002MY this is common issue...
If there is power and CAN signal and DIM still doen't work need to repair or replace DIM.

nyurch
Posts: 85
Joined: Tue Dec 15, 2009 4:00 pm
Year and Model: '98 S70GLT '02V70X/C
Location: Eastern PA

Post by nyurch »

Common dim failure. I sent my dash out and got it repaired and 3 years later the dim was shot again. Went to the scrap yard and swapped it with a used one from the same year and same numbers (this is crucial), v70 or xc will also swap if they are the same year and same number, just note your mileage if you go that route. It's around 150 to send for repair and your out of a car for about a week.

Yaworski
Posts: 66
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 3 times

Post by Yaworski »

Oh such wonderful news. I was hoping that you'd say, "Oh, that's the number 15 fuse." Any idea why this would have happened while my mechanic had the car?

Now the questions. "it with a used one from the same year and same numbers (this is crucial)" Same year makes sense. What do you mean by "same numbers"?

Also who does repairs on these?

Thanks.

Georgeandkira
Posts: 831
Joined: Tue Apr 07, 2009 8:24 am
Year and Model: 2007 V70 base
Location: Hudson & Champlain Valleys, USA
Has thanked: 27 times
Been thanked: 56 times

Post by Georgeandkira »

There are numeric labels and or stencils on the back.

XeMODeX and Cluster Fix are two companies.

User avatar
yagger
Posts: 348
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 6 times
Been thanked: 31 times

Post by yagger »

Total Auto Tech (San Jose) - third )))
And cheaper, I think. )))

nyurch
Posts: 85
Joined: Tue Dec 15, 2009 4:00 pm
Year and Model: '98 S70GLT '02V70X/C
Location: Eastern PA

Post by nyurch »

Do not send to myairbags.com! Shit warranty (mine lasted 3 years) go with xemodex or anywhere with lifetime warranty.

User avatar
yagger
Posts: 348
Joined: Thu Mar 24, 2016 4:29 pm
Year and Model: S60 2005 2,5T
Location: DreamLand
Has thanked: 6 times
Been thanked: 31 times

Post by yagger »

nyurch wrote: Tue Jul 21, 2020 5:20 pm mine lasted 3 years
Actually, this is max period for not quality repair...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post