IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Ignition whine in speakers Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" platform cars.

2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R

User avatar
vtl
Posts: 1625
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 42 times
United States of America
vtl

Re: Ignition whine in speakers

Post by vtl » Wed Oct 02, 2019 10:31 am

Long ground wire is a source of the ground loop. To be of the same potential both the HU and Yatour would need to have an equally short ground wires connected to the same ground point.

Power in, power out and the ground, yes.


05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

Yaworski
Posts: 41
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: Ignition whine in speakers

Post by Yaworski » Sun Oct 06, 2019 2:29 pm

vtl wrote: ↑
Mon Sep 30, 2019 12:58 pm
Have this one for power: https://www.amazon.com/gp/product/B0049MWUMQ It was DOA, but I was able to swap transistors and capacitor, so it works.
Would I put this in the power line for the Yatour box? The power line for the radio before the tap off to the Yatour? Or the radio power line after the tap?



Yaworski
Posts: 41
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: Ignition whine in speakers

Post by Yaworski » Sun Oct 06, 2019 2:32 pm

vtl wrote: ↑
Wed Oct 02, 2019 10:31 am
Long ground wire is a source of the ground loop. To be of the same potential both the HU and Yatour would need to have an equally short ground wires connected to the same ground point.

Power in, power out and the ground, yes.
The Yatour doesn't have a separate ground wire. I think that it is grounded through the DIN plug.



User avatar
vtl
Posts: 1625
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 42 times
United States of America
vtl

Re: Ignition whine in speakers

Post by vtl » Mon Oct 07, 2019 5:54 am

Yaworski wrote: ↑
Sun Oct 06, 2019 2:29 pm
Would I put this in the power line for the Yatour box? The power line for the radio before the tap off to the Yatour? Or the radio power line after the tap?
Between HU and Yatour, closer to Yatour.

I think I said that before, but I also had to break off the loop for line-in for my central speaker amp as well. The whine was minor, lot less than through ground, but still.


05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

Yaworski
Posts: 41
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: Ignition whine in speakers

Post by Yaworski » Thu Oct 10, 2019 10:31 am

vtl wrote: ↑
Mon Oct 07, 2019 5:54 am
Between HU and Yatour, closer to Yatour.
Another question. Should I ground the filter directly to the car's chassis, the radio's chassis, or through the ground wire for the radio?



User avatar
vtl
Posts: 1625
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 42 times
United States of America
vtl

Re: Ignition whine in speakers

Post by vtl » Thu Oct 10, 2019 10:52 am

Yaworski wrote: ↑
Thu Oct 10, 2019 10:31 am
Another question. Should I ground the filter directly to the car's chassis, the radio's chassis, or through the ground wire for the radio?
You do not need to ground it to the chassis.


05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

Yaworski
Posts: 41
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: Ignition whine in speakers

Post by Yaworski » Thu Oct 10, 2019 1:32 pm

vtl wrote: ↑
Thu Oct 10, 2019 10:52 am
You do not need to ground it to the chassis.
Just hook to the radio harness' ground wire?



User avatar
vtl
Posts: 1625
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 42 times
United States of America
vtl

Re: Ignition whine in speakers

Post by vtl » Thu Oct 10, 2019 9:02 pm

Hook to Yatour's harness. Either splice the cable or make your own male-female adapter. Solder noise suppressor's ground wire to harness' ground wire, cut +12v wire, one end solder to green (input), another to red (output).


05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

Yaworski
Posts: 41
Joined: Thu Nov 16, 2017 6:13 am
Year and Model: 2002 S60
Location: Western PA
Has thanked: 4 times
Been thanked: 1 time
United States of America
Yaworski

Re: Ignition whine in speakers

Post by Yaworski » Fri Oct 11, 2019 12:11 pm

The Yatour doesn't have a separate ground. I'm guessing that it is grounded though the DIN plug and the the DIN's shell. So solder the ground to the DIN shell?
Last edited by Yaworski on Fri Oct 11, 2019 1:40 pm, edited 1 time in total.



User avatar
vtl
Posts: 1625
Joined: Thu Aug 16, 2012 1:35 pm
Year and Model: 2005 XC70
Location: Boston
Has thanked: 3 times
Been thanked: 42 times
United States of America
vtl

Re: Ignition whine in speakers  Topic is solved

Post by vtl » Fri Oct 11, 2019 1:39 pm

Solder black wire to the GND wire in the cable. The idea is to feed the +12v through the noise suppressor.
These users thanked the author vtl for the post:
Yaworski


05 XC70 260k, 16 XC60 40k, 19 Tundra 1k

Post Reply
  • Similar Topics
    Replies
    Views
    Last post