IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Vida software won't let me diagnose the car.

How to buy, install and use VIDA, VADIS, DiCE, VMWare and all the questions and answers that come with these tools.
Olsi
Posts: 2
Joined: Sun Jan 26, 2020 8:55 pm
Year and Model: 2006 Volvo XC90 V8
Location: Albany
Has thanked: 0
Been thanked: 0
United States of America
Olsi

Vida software won't let me diagnose the car.

Post by Olsi » Sun Jan 26, 2020 9:22 pm

Hello. I have been trying to use a Vida software for quite some time but it doesn’t let me click on fault trace. This is what happens when I try to click it. The picture below
Attachments
B671B885-82A8-40A9-8857-D4A227D3F3C0.jpeg

User avatar
RickHaleParker
Posts: 4234
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 548 times
United States of America
RickHaleParker

Re: Vida software won't let me diagnose the car.

Post by RickHaleParker » Mon Jan 27, 2020 4:06 am

Click on [Details]
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

Olsi
Posts: 2
Joined: Sun Jan 26, 2020 8:55 pm
Year and Model: 2006 Volvo XC90 V8
Location: Albany
Has thanked: 0
Been thanked: 0
United States of America
Olsi

Re: Vida software won't let me diagnose the car.

Post by Olsi » Mon Jan 27, 2020 8:55 pm

This is what it says:
System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))
at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)
at System.Windows.Forms.AxHost.CreateWithoutLicense(Guid clsid)
at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)
at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)
at System.Windows.Forms.AxHost.CreateInstance()
at System.Windows.Forms.AxHost.GetOcxCreate()
at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)
at System.Windows.Forms.AxHost.CreateHandle()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.AxHost.EndInit()
at Vcc.Vida.DiagSwdl.UI.Components.NavImage.init()
at Vcc.Vida.DiagSwdl.UI.Components.NavImage..ctor()
at Vcc.Vida.DiagSwdl.UI.Diagnostics.NetworkForm.InitializeComponent()
at Vcc.Vida.DiagSwdl.UI.Diagnostics.NetworkForm..ctor(IWorkshopSession workshopSession, INetworkFaulttraceWF networkFaulttraceWf, IAdvancedWF advancedWf, IInfoElementsRepository infoElementsRepository, String currentCommToolName, ICarComRepository carComRepository, CarStatus carstatus, IDiagnosticSessionWF diagnosticSessionWf)
at Vcc.Vida.DiagSwdl.UI.Diagnostics.DiagnosticManager.GetNetworkForm()
at Vcc.Vida.DiagSwdl.UI.Diagnostics.DiagnosticManager._networkStatusButton_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at Vcc.Vida.DiagSwdl.GuiComponents.FlatButton.OnClick(EventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
-------------------------------------------------------
Loaded assemblies
ProgressHandler, Version=2.0.5394.27532, Culture=neutral, PublicKeyToken=null
System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
VehCom2, Version=2.0.5394.27561, Culture=neutral, PublicKeyToken=null
AppServices.VehicleAccess, Version=2.0.5394.27567, Culture=neutral, PublicKeyToken=null
System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
BizServices.ScriptRepository, Version=2.0.5394.27556, Culture=neutral, PublicKeyToken=null
ResourceManager.resources, Version=2.0.5394.27529, Culture=en-US, PublicKeyToken=null
BizServices.SoftwareProductInformation, Version=2.0.5394.27556, Culture=neutral, PublicKeyToken=null
System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
BizServices.NavImageRepository, Version=2.0.5394.27555, Culture=neutral, PublicKeyToken=null
System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
AxInterop.ISOVIEWXLib, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
AppServices.Scripting, Version=2.0.5394.27565, Culture=neutral, PublicKeyToken=null
BizServices.VehicleImageRepository, Version=2.0.5394.27556, Culture=neutral, PublicKeyToken=null
BizServices.VehicleResolver, Version=2.0.5394.27557, Culture=neutral, PublicKeyToken=null
ValueObjects, Version=2.0.5394.27551, Culture=neutral, PublicKeyToken=null
GuiComponents, Version=2.0.5394.27558, Culture=neutral, PublicKeyToken=null
AppServices.Dro, Version=2.0.5394.27562, Culture=neutral, PublicKeyToken=null
ICSharpCode.SharpZipLib, Version=0.84.0.0, Culture=neutral, PublicKeyToken=1b03e6acf1164f73
bjgsbz8z, Version=2.0.5394.27562, Culture=neutral, PublicKeyToken=null
ResourceManager.resources, Version=2.0.5394.27529, Culture=en-GB, PublicKeyToken=null
BizServices.AccessServer.DB, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null
BizServices.SoftwareOrdering, Version=2.0.5394.27566, Culture=neutral, PublicKeyToken=null
BizServices.SoftwareOrderRepository, Version=2.0.5394.27564, Culture=neutral, PublicKeyToken=null
AppServices.SoftwareOrderProcessing, Version=2.0.5394.27566, Culture=neutral, PublicKeyToken=null
BizServices.PartsLists, Version=2.0.5394.27560, Culture=neutral, PublicKeyToken=null
Util, Version=2.0.5394.27531, Culture=neutral, PublicKeyToken=null
BizServices.Scripting, Version=2.0.5394.27564, Culture=neutral, PublicKeyToken=null
BizServices.CarCom.VehicleServices, Version=2.0.5394.27554, Culture=neutral, PublicKeyToken=null
System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
BizServices.DiagnosticSession, Version=2.0.5394.27554, Culture=neutral, PublicKeyToken=null
BizServices.VehicleCommProvider, Version=2.0.5394.27562, Culture=neutral, PublicKeyToken=null
AppServices.WorkshopSession, Version=2.0.5394.27559, Culture=neutral, PublicKeyToken=null
ResourceManager, Version=2.0.5394.27529, Culture=neutral, PublicKeyToken=null
AppServices.EcuDataResolver, Version=2.0.5394.27559, Culture=neutral, PublicKeyToken=null
System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
BizServices.InfoElementsRepository, Version=2.0.5394.27554, Culture=neutral, PublicKeyToken=null
System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
BizServices.CarCom.DB, Version=2.0.5394.27553, Culture=neutral, PublicKeyToken=null
System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
System.Web.Services, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
Workflow, Version=2.0.5394.27569, Culture=neutral, PublicKeyToken=null
BizServices.DroResultFileProducer, Version=2.0.5394.27560, Culture=neutral, PublicKeyToken=null
-------------------------------------------------------
Loaded databases

User avatar
RickHaleParker
Posts: 4234
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 548 times
United States of America
RickHaleParker

Re: Vida software won't let me diagnose the car.

Post by RickHaleParker » Tue Jan 28, 2020 1:39 am

Olsi wrote:
Mon Jan 27, 2020 8:55 pm
This is what it says:
System.Runtime.InteropServices.COMException (0x80040154): Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

Something is not correct in the registry entries. The first one is a communication error. Try reinstalling the Dice software, Vida Media:\3PP\Products\DiCE\

Go to Vida Media:\Install\Utils\ You will find the other Windows Registry files, run them if reinstalling DiCE does not fix the problem.

If you run the EnableIEHostingxXX.reg make sure you run the correct one for your operating system 32 bit vs 64 bit.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger, Plant Ghent Belgium.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post