IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

V70XC Transmission Issues (flashing light + CEL)

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Thu Oct 27, 2011 6:49 pm

So after a long day of work at the hospital, I got back to my car (1999 V70XC 92K miles, tranny fluid flush 12000 miles ago) that had been covered during the cool rainy day and I started it and it wouldn't go into reverse. I tried rowing the gears back and forth and eventually it slowly rolled backwards, I put it into drive and it made it out. The shifts were taking longer than normal and occurring at higher revs on the stop and go traffic light route home over about 8 miles. Then I got onto the highway for the 3 miles I do there. As I got it up towards 50 or 60 the transmission light (arrow) started flashing and the CEL came on. I know that flashing lights = bad, but I had to make it the last mile home. I'm not sure where to go from here, but I'm worried about this. Any input or information would be very helpful.

Thank You,

Aaron



Jack Rock
Posts: 313
Joined: Wed Jun 02, 2010 8:46 am
Year and Model: 1998 V70R
Location: Stratford, Ontario
Has thanked: 0
Been thanked: 0
Jack Rock

Re: V70XC Transmission Issues (flashing light + CEL)

Post by Jack Rock » Thu Oct 27, 2011 6:57 pm

Start with checking the fluid level, best when warm. Look in your manual for proper procedure. The dipstick is a pain to read so give it a few tries. I'm guessing it's low. The CEL and flashing arrow simply indicates a transmission fault code, the flashing is a little obnoxious I know. Get your level right, get your CEL reset and go from there.


1997 850 T5 (gave up at 324,000km)
1998 V70 R AWD (gave up at 296,000km)
1998 S70 T5 (total loss - in a parking lot!)
1999 V70XC
1975 VW beetle
1960 Empi Sportster Dune Buggy

arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Thu Oct 27, 2011 7:55 pm

Went back out to my car, still warm and checked the fluid levels. They were dead normal. I disconnected the battery for about 5 minutes and started it back up. Before I engaged the starter the transmission arrow was flashing. I started the car, rowed through the gears a few times and disconnected and reconnected the battery to the same flashing arrow. I drove it a lap of my apartment complex, it seems to be shifting just fine now, but the arrow and CEl are still present.

Thoughts?



Jack Rock
Posts: 313
Joined: Wed Jun 02, 2010 8:46 am
Year and Model: 1998 V70R
Location: Stratford, Ontario
Has thanked: 0
Been thanked: 0
Jack Rock

Re: V70XC Transmission Issues (flashing light + CEL)

Post by Jack Rock » Thu Oct 27, 2011 9:22 pm

You'll need to get the code read, or buy a $40 scanner - worth it's weight in gold. If the arrow is there before even starting it, then some pre-test is failing like a bad solenoid or pnp switch. Does it drive like it's dragging a safe?


1997 850 T5 (gave up at 324,000km)
1998 V70 R AWD (gave up at 296,000km)
1998 S70 T5 (total loss - in a parking lot!)
1999 V70XC
1975 VW beetle
1960 Empi Sportster Dune Buggy

arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Thu Oct 27, 2011 9:44 pm

It seems to drive okay. Not like it's dragging or in winter mode. I'm going to have the CEL code read tomorrow, but I have to get to my med school rotation first and I wonder if I could do any damage by driving about 18 miles in stop and go traffic round trip with the car in this state. Thoughts?



arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Fri Oct 28, 2011 10:03 am

Had the codes checked and cleared. They were 756 and 1618. Lights stayed off for about 4 miles then started again with the transmission in limp mode. Any help with these codes is much appreciated as I've got this afternoon off an can get parts.

Thanks



arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Fri Oct 28, 2011 12:01 pm

On my searching it looks like either I'm looking at a new PNP(although that doesn't seem to be what this code is for) or a new set of solenoids (all of the posts that say they are going to try this have no long term follow up so I don't know if this works or not) or a new tranny.

Anyone have any experience with this?

Thanks



Jack Rock
Posts: 313
Joined: Wed Jun 02, 2010 8:46 am
Year and Model: 1998 V70R
Location: Stratford, Ontario
Has thanked: 0
Been thanked: 0
Jack Rock

Re: V70XC Transmission Issues (flashing light + CEL)

Post by Jack Rock » Fri Oct 28, 2011 4:00 pm

I haven't had experience with this but looking around the web tells me that 1618 is a faulty lead between trans and ecu. If this is true then it could explain the 756 as well. Check the connection on the top of the trans, check the cable for damage, maybe re-seat the transmission computer (battery disconnected of course).


1997 850 T5 (gave up at 324,000km)
1998 V70 R AWD (gave up at 296,000km)
1998 S70 T5 (total loss - in a parking lot!)
1999 V70XC
1975 VW beetle
1960 Empi Sportster Dune Buggy

arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Fri Nov 04, 2011 6:19 am

Time for an update. I ordered the solenoids and the PNP switch. I replaced the PNP switch yesterday evening and it drove fine for about 15 miles last night. I then drove into work today (8 miles, one short stretch of highway and then stop and go) and at the end of the highway part the arrow was flashing again and the CEL was on. I plugged in my code reader and lo and behold it had a new code! Well, it had the same p1618 but now it has p0734.

I'm not really sure what p0734 means, 4th gear ratio wrong doesn't really explain to me what the issue is. It didn't feel like it wanted to shift into fourth with the code cleared, but I'm not really sure. Any input or experience with this code would be appreciated.

Thanks
Aaron



arnabio
Posts: 33
Joined: Mon Nov 29, 2010 4:32 pm
Year and Model: 1999 V70XC
Location: Denver, CO/Bostom, MA
Has thanked: 0
Been thanked: 0
arnabio

Re: V70XC Transmission Issues (flashing light + CEL)

Post by arnabio » Fri Nov 04, 2011 3:22 pm

I broke down and had it towed to a transmission shop. Awaiting the estimate of the damage...



Post Reply